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Common issues in iOS kiosk app management

Issue 1

Device still in the kiosk mode even after the kiosk policy is disassociated from the device.

Possible Cause

The device might have lost connection with the portal. A weak internet connection can also cause this.

Solution

  • Check your internet connectivity. Kiosk mode will be removed from the device once it regains net connectivity.
  • If the device is still in kiosk mode, use Apple Configurator to remove the profile.
    1. Connect the device to a Mac that has the Apple Configurator app installed.
    2. Right-click the device and select Remove > Profiles > the configured Hexnode MDM profile.

Steps to remove profiles using Apple Configurator

Issue 2

Device gets stuck when the Single App kiosk is configured. The message, “Guided Access app unavailable. Please contact your administrator” is displayed when the user tries to unlock the device.

 Guided access mode when Single app kiosk is configured

Possible Cause

The app configured in the Single App kiosk policy is not present on the device.

Solution

Disassociate the policy from the device to disable kiosk mode. Now install the required app on the device. You can even install apps through Hexnode. After the app is installed, associate the policy with the device.

Issue 3

A single app kiosk is associated with the device. Hexnode portal shows that the device is in kiosk mode, but kiosk mode is not activated on the device. The app added in the kiosk appears to be greyed out on the device. No other apps can be opened. The device becomes unresponsive.

Possible Causes

  • The app configured in the Single App kiosk policy might not be compatible with the OS version of the device.
  • The app added in the kiosk policy might be an expired enterprise app.

Solution

  • Disassociate the policy from the device to disable kiosk mode.
  • Update the OS. If the issue was due to the incompatibility of the app with the OS version, then this step will resolve the issue. However, if the problem was due to the expired enterprise app, you will have to remove the greyed-out app from the policy and add the updated version of the app.

Issue 4

QR codes cannot be scanned when the device is in kiosk mode despite allowlisting the Camera app.

Possible cause

A system app called “Code Scanner” needs to be present in the kiosk for the user to be able to scan QR codes. This app might be getting blocklisted when the kiosk policy is getting applied.

Solution

Modify the kiosk policy associated with the device to include the system app “Code Scanner” in the list of allowlisted apps. In some cases, you may have to restart the device after the policy is applied.

Allowlisting
  • Troubleshooting Guides