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Troubleshoot MSI app installation errors

Hexnode UEM provides the option to install enterprise apps as a .msi file onto a Windows device. But sometimes the installation process may fail due to various reasons. This document provides insight into how to troubleshoot MSI app installation errors that occur commonly.

1. MSI app installation failed with an error message “Missing Agent app”

Description:

The error message indicates that the Hexnode Agent app is missing on the device.

Probable cause:

The Hexnode Agent app failed to get installed on the device during the enrollment process.

Possible solution:

You will need to re-enroll the device using the Hexnode Installer to install the Hexnode Agent app. As you enroll the device, be sure it is linked to a reliable internet connection. The most recent Hexnode Agent app will be downloaded and installed on your device after a successful enrollment.

2. Error 1722. “There is a problem with this Windows Installer package. A program run as part of the setup did not finish as expected.”

Description:

Windows Installer package is the Windows service that takes care of app installations on a Windows device. The error message indicates that there is a problem with the Windows Installer package while it tries to install the .msi file.

Probable cause:

The Windows Installer package might be disabled under Windows Services.

Possible solution:

Certain settings not properly configured on the Windows Installer package can lead to the failure of the installation of apps. Follow these steps on the device to troubleshoot this issue:

  1. On the Windows device, press Windows key + R to open the Run Dialog.
  2. Type services.msc in the Run Dialog, and then press Enter to open Services.
  3. Right-click the Windows Installer service, and then click Properties.
  4. If the Startup type box is set to Disabled, change it to Manual.
  5. Click OK to close the Properties window.

An alternate solution is to try to unregister and re-register the Windows Installer. Follow these steps on the device to do the same:

  1. Press the Windows key + R to open the Run command dialog box.
  2. Type CMD and press Enter.
  3. Type, msiexec /unreg in the Command Prompt and click Enter to temporarily unregister the Windows Installer.
  4. Then, type msiexec /regserver and click Enter to re-register Windows Installer.
  5. Restart the device for the changes to take effect.

3. Error 1603. “When you try to install a Windows Installer package: A fatal error occurred during installation.”

Description:

Error code 1603 indicates that an error occurred during the installation of a .msi file.

Probable cause:

This error code can occur if an older/present version of the app is already present on the device.

Solution:

Check if there is an older/present version of the app is present on the device and uninstall it. Then try reinstalling the app from the Hexnode portal.

4. Error 1618. “Another installation is already under progress.”

This error occurs when multiple installations are initiated at once. The Windows Installer package is responsible for the installation of apps and it only executes the installation of one app at a time. The other installation processes will be on ‘pending’ status and will later be executed.

5. Error 2715/2716/2717. Corrupted custom action scripts during installation.

Probable cause:

These errors can occur when the custom action script in the .msi file has been modified, deleted, or corrupted.

Solution:

Try downloading the .msi file once again from the website concerned or contact the issuer of the .msi file.

6. MSI app installation failed with an error message “The provided log path is invalid. Please provide a valid log path.”

Receiving error message for MSI app installation: The provided log path is invalid. Please provide a valid log path.

Description:

This error message that occurred as a result of the installation action for an MSI app indicates that the custom path specified for the output log file of the .msi file was invalid.

Probable cause:

This error may occur if:

  • The drive specified in the log path doesn’t exist on the device.
  • Admin enters invalid data in the input field.

Solution:

Configure the installation settings of the .msi file with a valid log path when installing the app via Policy or Actions.

  • Troubleshooting Guides