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Common errors while enrolling iOS and macOS devices in Hexnode
- 1. The new MDM payload does not match the old payload.
- 2. According to your corporate policy, only the following devices can be enrolled and can access the corporate resources: ……. Contact your IT administrator for more information.
- 3. A connection to the server could not be established.
- 4. Could not download the identity profile from the Encrypted Profile Service. The credentials within the Device Enrollment profile may have expired.
- 5. Apple’s MDM Certificate (APNs) is required for enrolling Apple devices. Please contact your administrator.
- 6. Unable to access the enrollment URL sent to an iOS device via Email.
- 7. The enrolled devices are not listed in Hexnode MDM portal even if the users have installed the profile.
1. The new MDM payload does not match the old payload.

Description
Error message while enrolling an iOS device.
Probable Cause
The device might already have an MDM profile installed in it.
Solution
To remove the existing MDM profile,
- On your iOS device, go to Settings > General.
- Scroll down and select Profiles and Device Management.
- Tap Hexnode MDM or in case you’ve previously enrolled in a different MDM, tap the name of that MDM provider.
- Scroll down and tap Remove Management > Confirm.
2. According to your corporate policy, only the following devices can be enrolled and can access the corporate resources: …….
Contact your IT administrator for more information.

Description
Error message while enrolling an iOS device.
Probable Cause
The device type might not be permitted to enroll in Hexnode.
Solution
- Go to Enroll > Settings in the Hexnode portal.
- Scroll down to Enrollment Restrictions > Device Models allowed, select iPhone or iPad based on the device type that you are using.
- Click on Save.
3. A connection to the server could not be established.

Description
Error message while enrolling an iPadOS 13 devices.
Probable Cause
The device type might not be permitted to enroll in Hexnode.
Solution
- Go to Enroll > Settings in the Hexnode portal.
- Scroll down to Enrollment Restrictions > Device Models allowed, select iPad.
- Click on Save.
4. Could not download the identity profile from the Encrypted Profile Service. The credentials within the Device Enrollment profile may have expired.

Description
Error message while enrolling macOS devices.
Probable Cause
The device type might not be permitted to enroll in Hexnode.
Solution
- Go to Enroll > Settings in the Hexnode portal.
- Scroll down to Enrollment Restrictions > Device Models allowed, check the box corresponding to macOS.
- Click on Save.
5. Apple’s MDM Certificate (APNs) is required for enrolling Apple devices. Please contact your administrator.
Description
Error message while enrolling an iOS device.
Probable Cause
You may not have configured an APNs certificate.
Solution
You need to set up an APNs certificate for an iOS device to communicate with the MDM server.
After logging in to your Hexnode MDM portal,
- Go to Admin tab > APNs.
- Click on Configure APNs Certificate.
- Click on Generate CSR Request > Download the self-signed-certificate from Hexnode > click Next.
- Click on Go to Apple Push Terminal > Login with your company Apple ID.
- Click on Create a Certificate to create the APNs certificate.
- Click on Choose file > Upload the self-signed certificate (hexnode_signed_casr.txt).
- Download the APNs certificate generated by Apple.
- Go back to your Hexnode MDM portal > Enter your company Apple ID > Upload the APNs certificate > Click Finish.
6. Unable to access the enrollment URL sent to an iOS device via Email.
Probable Cause
Hexnode MDM server may not be reachable to the users.
Solution
- Make sure that you have disabled Block all incoming connections in the Firewall settings.
- If users are outside the Local Area Network (LAN), verify that you have configured the NAT Settings so that the users can reach Hexnode MDM via public IP.
Go to System Preferences > Security & Privacy > Firewall > click Firewall Options > Uncheck Block all incoming connections > Click OK.
7. The enrolled devices are not listed in Hexnode MDM portal even if the users have installed the profile.
Probable Cause
The devices may not be able to reach APNs.
Solution
- Check your Wi-Fi network connectivity.
- In case Wi-Fi is disabled, make sure that your device has cellular data network connectivity.