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Common errors while enrolling in Apple Business Manager

1. Invalid Profile

troubleshooting apple dep-Invalid profile

Description

Error message during device activation.

Solution

  • Make sure that you have adequate MDM Licenses to manage your devices.
    1. Sign into your Hexnode MDM portal, head on to Admin tab > License > Check the License count.
    2. If the number of your enrolled devices has reached the maximum limit for your license, you need to upgrade the license to manage more devices.
  • Ensure that the Server Token has not expired.
    1. After signing into your Hexnode MDM portal,
      Navigate to Admin tab > Apple Business/School Manager > Select Apple DEP
    2. Click the DEP Settings button and check the date of license expiration.
  • In case the Server Token has expired, go to Apple Business Manager and sign in to your account > Click on Get Token to download a new DEP Token from your server. Learn more

  • Verify that you have pushed the DEP Policy to your iOS device.
    1. You can push the DEP Policy to your iOS device(s) by signing into your Hexnode MDM portal,
      Go to Admin tab > Apple Business/School Manager > Apple DEP
    2. Select DEP Devices > Choose the required device(s) > Click the Associate Profile button.
    3. Now, you need to wipe your device to re-enroll them into your Hexnode MDM account.

  • Check if the Pre-approved settings have been enabled in both Enrollment settings and Apple DEP settings.
    On your Hexnode MDM portal,

    1. Go to Admin tab > Enrollment
    2. If you have enabled the option Pre-approved Devices only under Enrollment Restrictions,
      1. Head on to the Admin tab > Apple Business/School Manager > Select Apple DEP
      2. Click the DEP Settings button > Check the option Add as Pre-approved Device > Click Save.
  • Ensure that the OS updates are not pending on any of the iOS devices that you are trying to enroll.
    In case there are pending OS updates, you need to remove the required devices from your Apple Business Manager account before executing the OS update.

    1. Go to Apple Business Manager and sign in to your account.
      1. Select Device Assignments under Devices.
      2. Choose the devices by entering either the Serial Number or Order Number of the devices. You can remove multiple devices by uploading a CSV file with the device details.
      3. Select Unassign Devices from the Perform Action under Choose Action > Choose Hexnode from the MDM Server > Click Done.
    2. After unbinding the device from DEP, complete the pending OS updates on your iOS device.
    3. Go back to your Apple Business Manager account and re-assign the devices to DEP.
    4. Now, sign into your Hexnode MDM portal and navigate to Admin tab > Apple Business/School Manager > Select Apple DEP > Click the Sync DEP button.
  • 2. Even after a successful sync, the device does not get listed in the MDM server on DEP page.

    Solution

    If you have enrolled the device in the MDM server using an enrollment method other than DEP,

    • Remove the device from Management.
    • Reset your iOS device to factory settings.
    • From your Hexnode MDM portal,
      Go to Admin tab > Apple Business/School Manager > Select Apple DEP > Click the Sync DEP button.

    Syncing with the MDM server lists the device on the DEP page.

    3. The configuration for your iPhone/iPad could not be downloaded. The configuration is not available

    The configuration for your iPhone or iPad could not be downloaded

    Description

    Error message during device activation.

    Solution

    • Check your network connectivity.
    • Additionally, check if the MDM server is reachable from another device in the same network.

    4. Cancelled.

    Description

    Error message during device activation.

    Solution

    • Check your network connectivity.
    • Connect the device to Apple Configurator and restore it. Restoring a device reloads iOS into it.
    • Try re-enrolling the device after restoring it successfully.

    5. A server with the specified hostname could not be found.

    Description

    A server with the specified hostname could not be found

    Error message during device activation.

    Solution

    • Check your network connectivity.
    • Furthermore, if the MDM server is not accessible from another device in the same network, execute appropriate changes to the server’s NAT settings.

    6. NOT_ACCESSIBLE.

    Description

    Error message while adding devices to the DEP portal.

    Probable Cause

    This error befalls if the device is either not eligible for DEP enrollment or already enrolled by another organization.

    Solution

    • Check if the device is eligible for DEP enrollment. If not, enroll the device via Apple Configurator.
    • Ensure the device is not already enrolled or maintained by another organization.

    7. Unable to view the MDM servers tab, after signing into the ABM portal.

    Solution

    • Make sure that the administrator has assigned the Device Manager role to you.
    • Sign into your Apple Business Manager account > Select Roles under People.

    • Also, ensure the admin has agreed to Apple’s terms and conditions.
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