Category filter

Troubleshoot issues with Hexnode Agent app on Windows

When you enroll a Windows device in Hexnode UEM, the Hexnode Agent app gets installed on the device. It is the Hexnode Agent app that sets up device configurations, performs remote actions, streamlines app management, imposes security controls, and locks down devices in kiosk modes based on instructions from the Hexnode portal.

This document deals with the various possible errors/issues that you might encounter in relation to the Hexnode Agent app on Windows devices.

1. “Hexnode Agent app is inactive on the device. Restart the Agent app to manage the device seamlessly.” error message is displayed.

Hexnode agent status is displayed as inactive in the device details page

Description

The Hexnode Agent app is indicated as inactive under Device Summary > Enrollment details > Hexnode Agent app version on the device details page. Remote actions like Execute Custom Script, Join AD Domain, Power off Device, Enable Lost Mode, etc. that require an agent app no longer get executed but remain under the Pending state in the Action History. However, Scan Device and Scan Device Location actions will continue to work on the device. And, policies, including all the restrictions, can be successfully deployed.

Probable Causes

  • The device is facing network connection issues.
  • Both Hexnode Agent and Hexnode Updater/Hexnode Update Helper services have been stopped (under Task Manager > Services).
  • Hexnode Agent has been removed from the device, i.e., if the Hexnode Agent folder (Local Disk (C:) > Hexnode > Hexnode Agent) has been accidentally deleted from the device.

Solution

Re-activate the agent app by using the following methods:

  • Re-establish the network connection.
  • Navigate to Task Manager > Services or the Services app and restart both the Hexnode Agent and Hexnode Updater/Hexnode Update Helper services.
  • Re-install the agent by running the Hexnode installer again:
    1. Launch the Hexnode Installer Setup app you had previously downloaded and follow the on-screen instructions.
    2. When the EULA policy is displayed, read the EULA and click on Agree and Enroll.
    3. The Hexnode Agent app gets downloaded and installed on the device with the previous configurations applied again.

2. Hexnode agent app not installed automatically upon enrollment

Description

For Native enrollment, PPKG enrollment, and Windows Autopilot enrollment, the Hexnode agent app is not automatically installed on Windows devices.

Solution

The Hexnode agent app will not automatically install on devices enrolled through these methods unless the “Install Hexnode Service App Silently on Windows” option is enabled in the Hexnode App Updates section in the Hexnode portal. Here’s how to enable it:

  1. Go to the Admin tab.
  2. Click on General Settings.
  3. Locate the Hexnode App Updates section.
  4. Enable the Install Hexnode Service App Silently on Windows Devices option.

Enable the 'Install Hexnode Service App Silently on Windows devices' option to automatically install the Hexnode agent on devices enrolled in Hexnode without the Hexnode agent app

Once this option is enabled, the installation process for the Hexnode agent app will begin automatically after about 5 minutes post enrollment .

Note that this setting needs to be enabled before the device is enrolled. If the device is already enrolled, you may need to unenroll and re-enroll it for the automatic installation to work.

3. Status continues to be “initiated” in Action History, after the Hexnode agent app installation was initiated from the Device Summary page

Description

After initiating the installation of the Hexnode agent app by clicking the refresh button next to the Hexnode Service (Agent) App status in the Enrollment Details section of the Device Summary for a Windows device, the status in the Action History remains “initiated” and does not update.

Workaround

You can verify the installation status of the Hexnode agent app from the device. Here are the steps to follow:

  1. Open the Event Viewer on your Windows device.
  2. Go to Application and Service Logs > Microsoft > Windows > DeviceManagement-Enterprise-Diagnostics-Provider > Admin.
  3. Search for Event Logs with Event IDs that have “19” as their prefix. These Event Logs are related to the installation of the Hexnode agent app.
  4. Check the details of the Event Log to see the installation status of the Hexnode agent app.

Status for Hexnode agent app installation can be seen in the Event Viewer on Windows devices

Please note that the installation of the Hexnode agent app will take some time and depends on the device’s network strength. The installation process can take up to a few minutes.

  • Troubleshooting Guides