Blocking unmanaged apps from accessing managed contacts in iOS

Avatar
expand collapsive

Hello all,
Any way to block third-party apps from accessing corporate contacts on iOS? The thing is, our sales team has put in a request to be allowed to work on their personal devices and has agreed to enroll in Hexnode. So, everything from corporate mail to contacts will be present on their personal devices. Happy to comply with their request. But a little skeptical about the data security issues that will follow. Anything to make our decision making easier?
Thanks in advance!

Tags:

All Replies

  • Avatar

    Kayle

    Participant

    Kayle

    Participant

    @Noam We blocked unmanaged apps opening documents of managed apps. Not sure if that will help you.

  • Avatar

    Noam

    Participant

    Noam

    Participant

    @Kayle I’m pretty new to this. How did you do it?

  • Avatar

    Kayle

    Participant

    Kayle

    Participant

    @Noam Once we enrolled the devices of our employees, we applied a policy in which Open documents from managed apps in unmanaged apps was disabled. You can find this setting under Business Container in the Hexnode portal.

    Don’t worry. You will get the hang of things soon.

  • Avatar

    Deborah Timothy

    Moderator

    Deborah Timothy

    Moderator

    Hi Noam,

    Thanks for reaching out to us.

    You can block third-party apps from accessing corporate contacts on iOS. To do so first make sure that corporate contacts are synced to the device by configuring the Exchange ActiveSync and/or CardDAV setting in the  Hexnode portal. This will make the contact managed. Check out our detailed help doc on configuring Exchange ActiveSync and CardDAV.

    To restrict unmanaged apps from accessing managed contacts:

    1. Open a New policy or an existing one. Provide a suitable Policy Name and Description. Select iOS > Business Container > Configure.
    2. Go through the settings and disable Unmanaged apps can read from Managed Contact Accounts if enabled.
    3. Associate the policy with the target devices. Click OK and Save the policy.

    Refer the detailed help doc on Business Container for iOS devices to know more. Hope I answered your query. Feel free to post your doubts here if you get any more.

    Cheers!!
    Deborah Timothy
    Hexnode MDM

  • Avatar

    Noam

    Participant

    Noam

    Participant

    @Deborah I made a custom group including all those devices. (There were a lot of devices and my lazy self didn’t want to add each one separately.) It worked out well for all devices except two of them. Can’t seem to figure out the reason. Should I try adding them as individual devices?

  • Avatar

    Deborah Timothy

    Moderator

    Deborah Timothy

    Moderator

    @Noam Please mention the version number of the phones in which you are facing this issue.

    Cheers!!
    Deborah Timothy
    Hexnode MDM

  • Avatar

    Noam

    Participant

    Noam

    Participant

    @Deborah Both are of the same model- iPhone 6S – OS Version 9.

  • Avatar

    Deborah Timothy

    Moderator

    Deborah Timothy

    Moderator

    @Noam The restriction in Business Container relating to Managed Contacts is only applicable to devices with OS version 12 and above.

    Cheers!!
    Deborah Timothy
    Hexnode MDM

  • Avatar

    Noam

    Participant

    Noam

    Participant

    @Deborah Thanks for pointing out the issue. Updated the two phones to the OS version 14. It did the trick.