Unable to install application on Mac

expand collapsive

Hey guys, I’m facing an issue with the app installation of F-secure antivirus v17.4 on my new Macbook pro. Tried installation using both the remote install action and Policy but failed. The following error msgs are displayed:

“The app could not be installed”.
“Failed to apply the action to the device. The current system configuration does not allow the requested operation.” (error msg when pushed through Policy)

I’m sure there are no issues with the installer packge (mpkg) because it was successfully installed on my Mac mini. Anyone got an idea what the problem is?

All Replies

  • Hexnode

    Chris Wheeler

    Moderator

    Thanks for reaching out on Hexnode Connect, @agnes.

    Could you please share the processor details of the macOS device in which you could install the application successfully? Also, have you tried installing the app manually on the device to see if that works?

    Chris Wheeler
    Hexnode UEM

    • This reply was modified 4 months, 4 weeks ago by  Chris Wheeler.
    • This reply was modified 4 months, 4 weeks ago by  Chris Wheeler.
    • This reply was modified 4 months, 4 weeks ago by  Chris Wheeler.
    • This reply was modified 4 months, 4 weeks ago by  Chris Wheeler.
  • Hexnode

    Chris Wheeler

    Moderator

    @agnes Thanks for the info. This is a case of Rosetta support on Apple Silicon Macs. It seems like F-Secure products can only be installed on Apple Silicon Macs with Rosetta since they haven’t yet released the full native support for M1 Macs.

    No worries, though. Using Hexnode’s Execute Custom Script action, you can run a script file to trigger a non-interactive installation of Rosetta on your remote Apple Silicon Mac that automatically agrees to the license.

    Below is the command to do so:

    This is likely to solve the app installation issue on your M1 Mac. Let us know how it worked out.

    Cheers!
    Chris Wheeler
    Hexnode UEM