Issue with ARD and screen sharing on M1 Macs

expand collapsive

OS: macOS Big Sur

Software: Apple Remote Desktop 3.9.4

Issue: Unable to remotely access any of the Apple MacBook Air M1 via ARD or Screen Sharing if filevault and firewall is enabled.

P.S. Tried to remote access after disabling filevault and/or firewall and it seems to work fine.

This situation is very unfortunate since we have to systematically activate both filevault and firewall on many our devices. Is there any troubleshooting I can do here? Let me know your suggestions.

All Replies

  • Participant



    Hey guys, noticed the same issue while rolling out our M1 Macs with Filevault and firewall ON. Tried testing the case in a few intel Macs and there seems to be no issue and ARD works alright. So I guess the issue is specific to silicon macs?

    Browsed many sites to find a fix but nothing really worked. Grasping at straws here. Any bit of help is welcomed.

  • Participant



    Hello folks,

    Apple support has confirmed that Intel-based Macs are restricted from accessing M1 Macs (FileVault and Firewall enabled) using Screen Sharing in certain OS versions. FileVault/Firewall must be disabled to allow Screen Sharing in such cases.

    However, M1 Macs (FileVault and Firewall enabled) can access Intel-based Macs without any issues.

    Apple Remote Desktop and Screen Sharing issues seem to be a common occurrence in several Mac computers with Apple Silicon. The bug has already been reported to Apple and is expected to be fixed in the latest OS updates.

    Update your macOS version and see if the issue gets resolved.