identifying offline devices outside geofence

expand collapsive

Hello experts, we are providing iOS devices to our employees working in transit. We’ve been making use of geofencing to manage devices but recently we noticed that if the device loses internet connectivity and goes out of geofence we are not getting notified at all.
am I missing something here? is there a way we can get a list of devices that went offline and is out of the geofence?

All Replies

  • Participant

    ripleyyy

    Participant

    Hey @ansel I am in the same boat as well… if the phone doesn’t have an internet connection and our workers take their phones outside the set geofence there is no way for us to know. Although when the phones were reconnected to the internet outside the geofence, we got notified immediately. I think its coz we had set that device if moved out of geofence must be marked as non-compliant. I guess if there is no internet connectivity there really is no way for us to find out…  I might be wrong here though…Do you guys have any idea on how to get the alert even without internet?

    Any ideas/suggestions are welcome.

  • Hexnode

    Emma Jones

    Moderator

    Hello folks, thank you all for reaching out to us!

    To perform any action through the Hexnode UEM portal on the device, internet connectivity is a prerequisite. Unfortunately, if your devices have gone offline, you cannot establish a connection with the devices to perform any actions on them.

    Although for the use cases you all have mentioned, there is a workaround to minimize the time duration between the device being offline/out of geofence and the admin being notified to take necessary actions.

    1. Go to the Admin tab:

    • General Settings > Configure inactivity settings to Mark devices as inactive after 15 minutes.
    • General Settings > Compliance Settings > Under ‘Mark your devices as non-compliant if’, check “Device becomes inactive” and “Device moves out of geofence”.
    • Notifications > Under ‘Notify the administrators on’, check ‘Device out of compliance’.

    2. Go to the Policies tab > Select your policy/create a new policy > General Settings.

    • Location tracking > Set location update interval to 15 minutes.
    • Geofencing > Add preferred geofence > Click OK.

    Let me explain what happens here.

    If your device continues to be inactive (the enrolled device has lost communication with the UEM server) after a 15-minute interval, your device will be marked as non-compliant, and the admin will receive a notification “Device – Device Name has gone out of compliance since in-active”.

    Also, due to the location update interval, your device will be periodically checked every 15 minutes and marked as non-compliant if it moves out of the geofence. Thereafter, the admin will receive a notification “Device – Device Name has gone out of compliance since the device is outside the specified geofence.”

    The key here is to configure both the location update interval and inactivity settings to the minimum time period (Available minimum: 15 minutes). This cuts the time you are unaware of the state of the device down to 15 minutes, helping you keep the devices in check and thereby reducing vulnerabilities.

    Please keep in mind that this is not a complete solution and use this only as a method to maximize your probability of getting alerts on the device status.

    If you are interested in learning more about the advanced management capabilities Hexnode UEM offers, please check out Geofencing and Compliance settings.

    Please try this out and keep me updated on how this works for you all!

    Cheers!
    Emma Jones
    Hexnode UEM

    • This reply was modified 7 months, 4 weeks ago by  Emma Jones.
    • This reply was modified 7 months, 4 weeks ago by  Emma Jones.
    • This reply was modified 7 months, 4 weeks ago by  Emma Jones.
    • This reply was modified 7 months, 4 weeks ago by  Emma Jones.
    • This reply was modified 7 months, 4 weeks ago by  Emma Jones.
    • This reply was modified 7 months, 4 weeks ago by  Emma Jones.
    Solution