Hexnode MDM app not getting updated in ROM-enrolled device

antonia
expand collapsive

Hey, I have a few devices enrolled using Hexnode’s ROM enrollment method. The devices were enrolled some time back and they were working fine till last few days. The Hexnode MDM app started crashing in a few of the devices recently. First I thought it was cus I didn’t update the app and I tried updating the app and still the same problem was there.. In the Action History page, it was showing that the action had failed with the error message:

“App not installed, The package conflicts with the existing package by the same name.”

Could someone tell me why this issue could be occurring?

All Replies

  • Chris Coleman

    Chris Coleman

    Hexnode

    Chris Coleman

    Moderator

    Hey Antonia,

    Thank you for reaching out to us!

    This issue could arise due to a signature mismatch between the new APK file and the current one. The key used for signing the new APK may be different from the one used to sign the earlier APK. This could result in the Hexnode UEM application not getting updated.

    You can contact your vendor and get the latest APK file signed with the same key. Upload the signed APK file to the Hexnode app inventory as an Enterprise application. Update the application with the newly signed APK file using the Install Application action from the Hexnode portal.

    Hope this clears your query.

    Cheers!
    Chris Coleman
    Hexnode UEM