Device owner ANdroid 5.0

Avatar
expand collapsive

Hi team,

I am trying to enroll an Android 5.0 device as DEVICE OWNER. 

I successfully followed the steps to use the ADB to push the Hexnode for work app with the shell command to make the device owner.

In the app itself, after entering the server, I need to grant permission to “device administration”, “Usage access” and “Notification Access”.

When I check the “usage access”, it brings me to the networks/wi-fi config. From there I don’t know where to go….

I’m unable to complete the Hexnode For Work profile configuration because of this, and thus cannot enroll the device.

Any idea what needs to be checked in the settings for the “Usage access” permission to be granted?

Thanks!

All Replies

  • Avatar

    Thomas Specter

    Moderator

    Thomas Specter

    Moderator

    Hi Thiago,

    Thank you for reaching out to us.

    Please do share the details of your device like the brand, model etc. Also, have you verified if your device is compatible with Android Enterprise? You can test this out, by installing the Hexnode for Work app as a normal app and trying to enroll it as a profile owner.

    Usage access permissions is generally found under the following path:
    Settings > Apps & Notifications > Advanced > Special App Access >Usage Access

    Once granted, the device shall be enrolled into Hexnode.

    Cheers!

    Thomas Specter
    Hexnode MDM