Block unwanted websites only on Chrome.

expand collapsive

Hi,
We have enrolled some of our corporate devices in Hexnode through Android enterprise (Device Owner). We have deployed Google Chrome as the only web browser.

As part of productivity hack, we wish to restrict our employees from accessing unwanted websites through Google Chrome.

We checked out the Web content filtering feature provided by Hexnode. But we understand that it is only supported on Samsung devices and the ones we are deploying are not Samsung phones.

Any suggestions on achieving this would be helpful.
Thanks in advance!

All Replies

  • Hexnode

    Archer Woods

    Moderator

    Hey @kayleigh,

    Thanks for reaching out to us!

    As you mentioned, Samsung users can directly use the Android Web Content filtering feature to restrict user access to specific websites. This prohibits web access to the specified URLs entirely, and the restriction also applies to the Google Chrome browser.

    For other(non-Samsung) users, one can use the App Configurations policy to set parameters to blacklist access to websites on Google Chrome. This feature is supported on Android devices enrolled in Android Enterprise as Device Owner and Profile Owner. Since your devices are already enrolled as Device Owner, you are good to go.

    The intended app must be installed on the device for an App Configurations policy to take effect. However, since most devices come with Google Chrome as a system app, you need not explicitly install it on your device unless otherwise.

    Blacklist URLs on Chrome:

    1. Navigate to Policies > Android > App Configurations > +Add new configuration.
    2. Choose the Google Chrome app and navigate to the Block access to a list of URLs option.
    3. Specify the URLs to be blacklisted in the following format: [“https://www.espncricinfo.com”, “https://www.amazon.com”]
    4. Associate the policy with your target devices.

    Hopes this answers your query.

    Cheers!

    Archer Woods

    Hexnode UEM

    Solution
  • Hey so we want our users to access only certain URLs through Chrome browser.
    So in app configurations we filled “Block access to a list of URLs” field wit [“*”] and
    “Allow access to a list of URLs” with the URLs in the form [“hexnode.com”]
    But now after setting and applying policy, we are not able to access any url at all. Is there something I am doing wrong? Pls help.

  • Try leaving Block access to a list of URLs field empty and just add the urls u want to access in Allow access to a list of URLs field.
    If you want to verify the same after applying to devices, check in chrome://policy page in chrome app in device and make sure the values are shown correctly against URLWhitelist and URLBlacklist.

  • @ivy we tried out your solution and here’s what happened.  whitelisted urls are displayed for URLWhitelist in the Chrome policy. But here’s the catch. Urls that are not whitelisted could be accessed as well. So still looking for ideas…

  • Hexnode

    Emma Jones

    Moderator

    Hello @eli, we appreciate you reaching out to us.
    Our team tested the case you mentioned with “*” in the block list and could not recreate the mentioned error. Therefore, we suggest you configure the policy once again, keeping in mind the following:

    • Ensure that you have entered the correct web address. Also, add the alternate web address in the Allow access to a list of URLs field.

    Please try this out and keep us posted on any updates. Also, if you have any other queries, feel free to reach out to us anytime!

    Regards
    Emma Jones
    Hexnode UEM

    • This reply was modified 1 month, 2 weeks ago by  Emma Jones.
    • This reply was modified 1 month, 2 weeks ago by  Emma Jones.
  • Hexnode

    Emma Jones

    Moderator

    Welcome back @ivy, great to see you again!
    While filling URLs in the field,  https://*, http://hexnode.com/* and * only provide the desired outcome. “*” anywhere else in the URL does not lead to the expected results.

    As an example, for the following entries filled in the “Block access to a list of URLs” field:

    • https://* – Denies all HTTPS requests to any domain.
    • * – Denies all requests, including URL schemes, except those in “Allow access to a list of URLs”.
    • http://hexnode.com/* – Denies all HTTP requests to hexnode.com and any subdomains but allows HTTPS and FTP requests.

    Cheers!
    Emma Jones
    Hexnode UEM