Wi-Fi on AE device owner

expand collapsive

Hey everyone
My company has bought samsung galaxy S20 for the new employees to work on. (I know, lucky idiots!!) Planning to enroll the devices in Hexnode as AE device owners. Please brief me on setting up Wi-Fi policy.

All Replies

  • Hexnode

    Deborah

    Moderator

    Hello Floris,

    Thanks for reaching out to us.

    Use the QR code method to enroll those devices. Then you will be able to push Wi-Fi configurations without applying a separate Wi-Fi policy. Go to Enroll > Platform Specific > Android Enterprise. From QR code settings, scroll down to Wi-Fi Settings, select Add Wi-Fi network configuration to QR code and give the details of your network. The device will be connected to that Wi-Fi network right from the initial setup.

    AE-DO-QR_code_enrollment

    Hope that answered your query.

    Cheers!!
    Deborah Timothy
    Hexnode UEM

  • Participant

    Cecelia

    Participant

    @Deborah Thanks. Even I needed that hack badly. Have always been a fan of QR codes. Will this prevent the employees from connecting to other Wi-Fi networks after enrolling to Hexnode? Everyone seems too eager to connect to the wi-fi of the restaurant down the street. Tired of conducting “awareness sessions”.

  • Hexnode

    Deborah

    Moderator

    Hello Cecelia,

    Simply configure a policy that has the option “Configure Wi-Fi” disabled from Android > Advanced Restrictions and apply it to the devices. The users will no longer be able to connect to another Wi-Fi. Please note that this restriction works only for devices enrolled in Android Enterprise.

    Cheers!!
    Deborah Timothy
    Hexnode UEM

  • Participant

    johana

    Participant

    Hey all,

    Wi-Fi works fine. But, I cant find the SSID displayed on the portal. Instead it shows something like unknown SSID. It is the case with Android Enterprise devices.

    When it comes to generic Android, the SSID is shown on the portal.

    How do I fix it?

  • Hexnode

    Catherine George

    Moderator

    Hi @johana,

    It seems not to be an issue.

    The message Unknown SSID occurs when Hexnode is unable to fetch the SSID from the device. Hexnode requires the device to have the location services turned on and the location permission granted for the Hexnode app to retrieve the SSID.

    No matter how the devices are enrolled, it is a requirement for all types of Android devices. The generic devices would have shown the SSID because these configurations would have been done already.

    Kindly enable these settings on the device. Then, perform a Scan Device action. The SSID will soon be reflected on the portal.

    Feel free to contact us for more queries

    Catherine George

    Hexnode UEM