User not shown on login window

expand collapsive

Hello everyone, I created a new user on Macs (Bigsur) using the terminal, however the account is not visible in the login window. How can I solve this issue.

All Replies

  • Hexnode

    Evin Lee

    Moderator

    Hi @kody,
    Thanks for reaching out to us.
    Could you please check if FileVault is enabled on the device?

    Thanks
    Evin Lee
    Hexnode UEM

    • This reply was modified 2 months, 3 weeks ago by  Evin Lee.
    • This reply was modified 2 months, 3 weeks ago by  Evin Lee.
    • This reply was modified 2 months, 3 weeks ago by  Evin Lee.
    • This reply was modified 2 months, 3 weeks ago by  Evin Lee.
    • This reply was modified 2 months, 3 weeks ago by  Evin Lee.
    • This reply was modified 2 months, 3 weeks ago by  Evin Lee.
  • Participant

    L@Yt0N

    Participant

    @kody
    I also had a similar issue on my mac. Under System Preferences – Security & privacy – Filevault, there will be a message “Some users are not able to unlock the disk “and an “Enable Users” button corresponding to it. You can click on the button and provide the account’s password. Then, the newly created account will appear on the login screen after restarting the device.

  • Hexnode

    Evin Lee

    Moderator

    Hi @kody,

    Thanks for replying.

    The newly created user account using the terminal will not be shown on the login window because the created user doesn’t have the secure token. Only user accounts with Secure Token enabled can access a FileVault-enabled macOS device. Hence to solve the issue, you can grant a secure token to the user account from the Hexnode portal. You can go to Manage > Actions > Grant Secure Token and enter the Administrator and Target account details. Then click on Grant Token to provide a secure token to the newly created user.

    Hope this answers your query.

    Cheers!
    Evin Lee
    Hexnode UEM

    Solution