Time limit policy not working consistently on my Mac

expand collapsive

The time limit policy doesn’t seem to be working consistently on my Mac. We’d set the time limit to prevent access between 7PM and 11PM but could still login and access the device during this period on few occasions. It’s surprising because on another day, the user account is automatically logged at the specified period and the policy seems to be working just fine. Is this the expected working?

All Replies

  • Thanks for reaching out in Hexnode Connect, Aaron.

    Sorry to hear about the issue you’re facing. That is not how the Time Limits feature for macOS should work.

    Please specify the OS version of your Mac so that we can look into this matter. Also, have you tried deploying the policy to a different Mac to see if that works?

    Chris Wheeler
    Hexnode UEM

  • Participant



    Had the exact same issue happen to us! From what we inferred, the issue is with the Mac version. Didn’t work on Monterey devices but worked as expected on devices running Mojave. Not sure if Apple removed support for older versions or it is an MDM issue.

  • Hey, Aaron. On testing from our end, it seems like the Time Limits feature works perfectly fine on Mojave and not working as expected on devices running Big Sur and Monterey. We can confirm this is not an issue associated with Hexnode UEM. However, we’ll keep looking into this and keep you posted on any updates.

    Chris Wheeler
    Hexnode UEM