Sync Android devices with Hexnode MDM

Avatar
expand collapsive

When I open the hexnode app on the android device, I see a sync icon at the top left. On clicking this icon, the pending actions gets synced with Hexnode. Where in the portal is the setting to configure this automatically?

All Replies

  • Avatar

    Grace Baker

    Hexnode

    Grace Baker

    Moderator

    Hey, Thanks for reaching out to us.

    You can automatically sync your device with MDM server from the Hexnode portal:

    • Navigate to Admin-> General Settings-> Periodic Sync (Android).
    • Click on the drop-down list next to Periodic sync behavior.
    • You will have the following options to choose from:
      Background sync: On choosing Background sync, the devices may not sync with the Hexnode server if the battery saver or data saver mode is turned on. This might obstruct the successful association of policies and actions.
      Foreground sync: On choosing the Foreground sync, there will be no trouble in the association of policies and actions. The devices will be synced with the Hexnode server even if the device is in battery saver or data saver mode. Please note that this might lead to high battery consumption and a non- dismissible notification on the device.
    • Click Save.

    Please check out our help doc on syncing devices automatically for more info.

    Cheers!
    Grace Baker
    Hexnode MDM

  • Harper

    Harper

    Participant

    Harper

    Participant

    Above post says the method to sync android devices with Hexnode automatically, how can this be done manually?

  • Avatar

    Thomas Specter

    Hexnode

    Thomas Specter

    Moderator

    Hi Harper,

    Thank you for reaching out to us.

    This can be done by manually initiating a scan action in an ad hoc manner, this shall immediately attempt connection with the device, and perform the device scans.
    Manual sync

    Cheers!

    Thomas Specter
    Hexnode MDM

  • Avatar

    Louie

    Participant

    Louie

    Participant

    Background sync not working. Mobile data is used on the devices so don’t want to foreground sync.

  • Deborah Timothy

    Deborah Timothy

    Hexnode

    Deborah Timothy

    Moderator

    Hello Louie,

    Thank you for reaching out to us.

    Please ensure that the device is not in Battery/Data Saver mode. The device should also be unlocked for the background sync to work.

    Cheers!!
    Deborah Timothy
    Hexnode UEM

  • Avatar

    Louie

    Participant

    Louie

    Participant

    Haven’t put device in data saver mode. Have set up a restriction to disable power saving mode too.

  • Deborah Timothy

    Deborah Timothy

    Hexnode

    Deborah Timothy

    Moderator

    @louie

    Since you have disabled the restriction Power saving mode, I am assuming that you have a Samsung Knox device as this restriction works only on Samsung Knox 2.8+ devices. Make sure that the restriction Sync data in background is enabled. If it is disabled, the device might go into Data Saver mode. You can find this restriction in Policies > New Policy > Android > Advanced Restriction > Allow Sync Settings > Sync data in background.

    Cheers!!
    Deborah Timothy
    Hexnode UEM

  • Avatar

    Leon

    Participant

    Leon

    Participant

    Might sound dumb but here we go, how is power saving different from data saving?

  • Avatar

    Louie

    Participant

    Louie

    Participant

    @leon

    Data Saver is used so as to reduce data usage. I guess all of us have been in a situation where our mobile data gets over way too fast due to some apps. Enabling this option will stop apps from running in the background without your permission.

    Power saving/ Battery saver mode is used to increase battery life. This will stop the frequent syncing and location checking on the device. You can also give permission to decrease the brightness, limit CPU speed and so on to save power.


    @deborah
    worked