remote view showing “connecting to device”

expand collapsive

One of our employees had some technical issues with his device. I tried turning on Windows Remote View to view the device from office. However, the remote view window kept showing “Connecting to device.” How can I solve this problem?

All Replies

  • Hexnode

    Evin Lee

    Moderator

    Hi @hillyhilton,

    Thanks for reaching out to us.

    The Hexnode Remote Assist app is used to begin a remote view session on the Windows device. When you start the session from the portal, this app creates a permission request to begin remote view on the device. And, the user has to grant permission for the app to start the session. The Hexnode portal displays “Connecting to device” while the permission request is sent to the device. You may see it for a long time if the user has not given permission for the app or if the device is not reachable. Hence, please make sure that the user has granted permission to the Hexnode Remote Assist app. Also, ensure that the device is turned on and has an active internet connection.

    If it doesn’t solve the issue, please check out our troubleshooting doc on fixing remote view issues on Windows devices to know more.

    Hope this helps. Do reach out if you’ve got further queries.

    Regards!
    Evin Lee
    Hexnode UEM

    Solution
  • Participant

    hillyhilton

    Participant

    Thank you, @Evin Lee. The problem was with the user’s internet connection. After inspecting the device with remote view, I found that our enterprise app was having trouble running on his device since the time and date on the device were incorrect. so, what can be done here to avoid such situations in the future.

  • Hexnode

    Evin Lee

    Moderator

    Hi @hillyhilton,

    You can restrict users from changing the date and time settings on Windows devices from the Hexnode portal. Here is what you need to do.

    1. Navigate to Policies > Windows > Advanced Restrictions > Allow Device Functionality.
    2. Uncheck the ‘Users can change date and time’ option.
    3. Associate the policy with the required devices.

    Hope this suits your requirements.

    Cheers!
    Evin Lee
    Hexnode UEM