HexCon is coming to NYC. Catch the early-bird price before the time's up! Book me a spot

Can’t connect to Remote View on WindowsSolved

Participant
Discussion
2 weeks ago

Hello

I have been trying to initiate a remote session on a user’s Windows device, but it is getting stuck in the “Connecting to device…” state.

I have followed the exact steps in this help document:

https://www.hexnode.com/mobile-device-management/help/how-to-enable-remote-view-for-windows-10-devices/

I can assure that the user has agreed to the required permissions in the Remote assist app. Am I missing anything or is it a glitch from the Hexnode side?

Replies (1)

Marked SolutionPending Review
Hexnode Expert
2 weeks ago
Marked SolutionPending Review

Hello @eugene

Thank you for reaching out to us.

The status message “Connecting to device…” describes the intermediary stage where the Hexnode server is trying to establish a secure connection with the device. Generally, this stage progresses once the user grants the remote view permission on the device end. Assuming the device is online, and the user has accepted the required permissions, the required port (443) for the connection may be blocked by the device’s firewall. To overcome this, you can follow these steps:

  • To open Windows Firewall Settings, press Win + R keys and enter “firewall.cpl”.
  • In the Firewall settings window, click on “Allow an app or feature through Windows Defender Firewall” on the left side.
  • Click on the “Change settings” button at the top.
  • Scroll through the list of allowed apps and features to check if the Hexnode Remote Assist app is already listed and has both Private and Public boxes checked.

I hope this resolves your problem. For any further issues, please feel free to refer to our troubleshooting guide regarding the common problems faced during remote view sessions on Windows.

Best regards,
George
Hexnode UEM