Can’t answer calls in kiosk

Avatar
expand collapsive

I’m kinda in a deadlock here. We have some conferences tomorrow which all our employees must attend. So I’ve added the conference app to a single app kiosk and pushed it to our employees’ phones. The catch is, when they lock the screens, they can’t answer the calls. What should I do? All phones run on Android 10, and enrolled as device owner. Please help urgently!

All Replies

  • Gabriel Galbraith

    Gabriel Galbraith

    Hexnode

    Gabriel Galbraith

    Moderator

    Thanks for reaching out to us, @Wang!

    Ensure that you have granted all the permissions required by the app to answer the calls. Please do inform us if the users are still unable to answer calls. We’ll check out the app and find out any possible issues.

    You can also implement a temporary solution. In Policies > Kiosk Lockdown > Android Kiosk Lockdown, under Peripheral Settings, navigate to Hardware/software buttons. Here, you can enable the Disable power button feature and also uncheck the Users can turn device Off option. This will let the device always stay awake, and now the employees can always take calls.

    Disabling power button

    When the device screen is always on, anyone will be able to view the content displayed in it. So, it would be best if you revert these settings after the conference. Please do note that on Samsung Knox devices running on Android 5.0 – Android 8.1.0 and on devices enrolled in Android Enterprise, disabling the power button will clear the lock screen PIN, unlock pattern, or password.

    Hope that resolves the issue.

    Cheers!
    Gabriel Galbraith
    Hexnode UEM

  • Avatar

    Wang

    Participant

    Wang

    Participant

    Thanks, app is working fine now. Was some permission issue

  • Avatar

    Darcy

    Participant

    Darcy

    Participant

    hey we’re having some issues with calls lately cuz most employees are working from different locations. so the network may vary, and they’ll need to choose from different wifi networks or switch to data accordingly. Since the devices are in kiosk, how do they do that

  • Gabriel Galbraith

    Gabriel Galbraith

    Hexnode

    Gabriel Galbraith

    Moderator

    Hey there, @Darcy! Thanks for reaching out!

    You can give the users maximum network connectivity options via Peripheral Settings. Navigate to Policies > Kiosk Lockdown > Android Kiosk Lockdown > Peripheral Settings > Network. Here, you can enable a bunch of features such as Users can turn Wi-Fi on/offConnect to and switch between saved Wi-Fi networksAdd hidden Wi-Fi networksShow all available Wi-Fi networks, Users can disconnect from currently connected network and Users can turn mobile data on/off. This will let the employees connect to new networks, add hidden networks and also switch to mobile data.

    Enabling network settings

    Hope that helps.

    Cheers!
    Gabriel Galbraith
    Hexnode UEM