Update the Hexnode Agent app

Alondra
expand collapsive

The script that I was trying to run on my device failed with a message saying that “This feature requires Hexnode Agent app version 4.2.2 or above to be installed on the device”. This app was automatically installed during enrollment and I don’t know where to get its update. Can anyone let me know how to update it
I have to run the script on a considerable number of devices, so, a remote update method would be much appreciated. Thanks in advance!

All Replies

  • Avatar

    Nora Lang

    Hexnode

    Nora Lang

    Moderator

    Good morning @Alondra, thank you for letting us know your concern.

    Yes, the HexnodeAgent is automatically installed on Windows devices when it is enrolled in Hexnode using the Hexnode Installer app. You can automate the update of the agent app and other Hexnode apps on your devices with the help of the Hexnode Update Helper. To ensure automatic agent app update, go to Admin > General Settings > Hexnode Update Helper and make sure that the option “Update Hexnode apps silently on Windows devices” is checked. Note that the default configuration of this option is checked. Once this is done, the app will be automatically updated.

    Additional Note: Custom script can only be executed on Windows devices enrolled in Hexnode using the Hexnode Installer app. If you have a device enrolled via the native “/enroll” method on which you have to execute the script, please re-enroll the device using the Hexnode Installer app.

    Hope this helps!
    Nora lang
    Hexnode UEM

  • Alondra

    Alondra

    Participant

    Alondra

    Participant

    Thank you for the response Nora, but this is not working for us. I have updated the admin configurations and I am still getting the same error message while pushing scripts.

  • Avatar

    Nora Lang

    Hexnode

    Nora Lang

    Moderator

    If there is an update for the installed HexnodeAgent app, Hexnode will automatically push an “Update Hexnode app” command to the device. Check the status of this action in the Action History; if this is “Inprogress” or “Failed” wait for some more time for the update to get installed. It may take a few hours to complete. Once this action succeeds, you can proceed with the script execution.

    If the status of the action in the Action History is “Success”, try script execution again after restarting the device, that might resolve the issue.

    Hope this helps!
    Nora lang
    Hexnode UEM

  • Alondra

    Alondra

    Participant

    Alondra

    Participant

    The action was still in progress while I pushed the script. All my devices except 1 got updated. Since the action was taking longer time on that machine, ‘ve tried re-enrollment, that too worked fine.