Problem accessing QR Code scanner from the device

Agneta
expand collapsive

Hello Hexnode Community,

We are managing a few iOS devices for our client company. Some of the devices is reported to have an issue with the QR code scanner. They claim that the QR code scanner icon was accessible on the control center earlier. But after the multi-app kiosk policy is set up on the device, the icon seems missing on control center.

To resolve the same, we tried enrolling two of our iOS devices, and applied the same multi app kiosk policy. One of them worked fine, but the other one raised the above issue. As a workaround, I gave it a shot erasing all the content & settings and the issue was fixed on the second device. Also, tried disenrolling the device and the QR code scanner works as expected.

But we can’t have these heuristics as the only possible solutions on our client devices – to disenroll the devices from our side or asking the client to wipe the devices.

It happens as soon as the multi app policy is applied from the portal. Any clues on why this happens?

All Replies

  • ybeees

    ybeees

    Participant

    ybeees

    Participant

    I’ve been thru some kind of a similar experience with an iOS. Instead of the multi-app kiosk policy, I’d applied the whitelisting to it. normally, scanning a QR code opens the corresponding link in safari. now the behaviour is contrasting. In the new normal, when I scan the QR code using camera, the QR code reader opens up but not the required link. As the whitelisting policy remains associated, I almost bought into the idea that the default browser is blacklisted too. (Whitelisted safari, but in vain) The QR code scanner functions well after I removed the policy. Seems like an analogy between the two!

  • Lovisa Linn

    Lovisa Linn

    Participant

    Lovisa Linn

    Participant

    I guess both of these are related. Check if any camera restrictions are turned on.

  • ybeees

    ybeees

    Participant

    ybeees

    Participant

    No restrictions applied.


  • Agneta

    Agneta

    Participant

    Agneta

    Participant

    Same here. No other policies except the multi app kiosk policy.

  • Avatar

    Skyler

    Participant

    Skyler

    Participant

    Hello folks,
    I presume it is with the update from iOS 13 that causes the issue. @agneta @ybeees Cud u verify the OS versions? The problem with QR code scanner is commonly seen on the devices running iOS 14+.
    Use the relevant settings on the device in getting the QR code scanner back in business. Go to the settings app and search for something like ‘code’. Next, toggle on the option ‘Scan QR Codes’. This enables the QR functioning of the camera app.
    Hope this settles your prob.

  • ybeees

    ybeees

    Participant

    ybeees

    Participant

    That’s right. It was iOS 14.3. And the workaround helped. thanks @skyler for your reply.

  • Agneta

    Agneta

    Participant

    Agneta

    Participant

    @skyler our client devices are all running iOS 14.2+. It helped a few, but some still face the issue.

  • Avatar

    Catherine George

    Hexnode

    Catherine George

    Moderator

    Hey All,

    Happy to be of help,

    According to the current workflow of iOS (from iOS 14+), the in-built QR code scanner gets blocked while the blacklisting/whitelisting policy is applied from any MDM solution. Since basically, a multi-app kiosk policy also performs blacklisting by blocking all the apps except the specified ones. This, in turn, generates the issue with your @agneta client devices too.

    Therefore, the system app – com.apple.barcodesupport.qrcode should be explicitly permitted on the devices whenever these policies are applied. You will have to modify the kiosk lockdown policy or the blacklist policy to add the Code Scanner app among the other permitted System apps. Including the Code Scanner app among the whitelisted apps or adding it to the multi-app kiosk completely eradicates the problem with the QR code scanner.

    Regards,

    Catherine George
    Hexnode UEM

  • Agneta

    Agneta

    Participant

    Agneta

    Participant

    That was extremely helpful. I was wondering if I should ask the client for a full reset on the device. thank you @catherine-george.