Password not accepting policy requirements in macOS Sonoma

expand collapsive

We updated our Mac devices to Sonoma 14.0. After updating, when the users tried logging in to their devices they were prompted to set a new password….which was fine.
But the system is not accepting the password even when the new password is set as per hexnode’s policy requirements. I keep getting the error “Your password does not meet the requirements of the server.” even when I am satisfying all the required server requirements.

Tried multiple password variation but unable to set one. Does anyone have any idea why this is happening and how can I fix this??

All Replies

  • Participant



    Restart doesn’t help on my devices. I was able to bypass the issue after deleting the policy for one of my devices. But we have to maintain compliance so we can’t remove the policy for all devices.

  • Hi everyone, welcome to Hexnode Community!

    The issue of device passwords not meeting the password requirements is experienced on Sonoma (macOS 14) devices. Until Apple resolves the issue or presents a troubleshooting mechanism, the following alternatives can be carried out:

    Method 1

    Attempt a device restart, and then proceed to set a new password as per the requirements.

    Method 2

    If another user account is already present on the device, attempt to log in to that account and then proceed to restart the device. After restart, set a new password as per the requirements.

    Method 3

    Initiate a password reset from the device’s recovery mode. Follow the steps to reset the password.

    1. Shut down the device.
    2. Press and hold the power button to enter the recovery mode.
    3. In the Utilities menu, select Terminal.
    4. Type resetpassword and press enter.
    5. A window will pop up allowing you to change the passwords for user accounts on the device.

    Method 4

    If the issue occurs on a device with a single user account, create an admin account on the device using the following steps:

    1. On the Hexnode portal, go to the Manage tab.
    2. Select the required devices.
    3. Click Actions > Create User Account.
    4. Set the Account type as Administrator and configure the account settings.
    5. Click Create to create an admin account on the devices.

    After creating the admin account, log into it and reset the password of the affected user account.

    Method 5

    Remove the existing password policy associated with the device and follow these steps:

    1. Allow the user to log in to the account.
    2. After the user has logged in, re-associate the password policy with the device.

    Please feel free to reach out in case of any further queries.

    Best regards,
    Kenny Markovic
    Hexnode UEM