Mac agent not getting installed

niklaus
expand collapsive

Recently enrolled a few hundred mac devices into Hexnode. The agent app didn’t get installed in a few of them. I tried to re-initiate the installation from the portal but it failed. Can I get a PKG file to install the agent manually? Some of the features don’t work without an agent right?

All Replies

  • mikael

    mikael

    Participant

    mikael

    Participant

    What happened when you initiated the installation from the portal?

  • niklaus

    niklaus

    Participant

    niklaus

    Participant

    The status of the agent app changed from to Initiated and then back to No

  • mikael

    mikael

    Participant

    mikael

    Participant

    What about in the action history?

  • niklaus

    niklaus

    Participant

    niklaus

    Participant

    The status got stuck in the initiated state. Waited for a few hours. No response. Tried initiating it again. Got an error which said “Install request is a duplicate”.

  • Chris Coleman

    Chris Coleman

    Hexnode

    Chris Coleman

    Moderator

    Hey Niklaus,

    Thank you for reaching out to us!

    The Hexnode Agent app installation getting stuck in the Initiated state could mean an app installation already running on the device, or the installation is getting delayed due to some technical issues. You can wait for the app installation to complete for some time. If the app installation is still not getting successful after a while, you can try out the below-given troubleshooting methods:

    • Restart your device.
    • Update your device to the latest OS version.
    • Reset your device by performing a Wipe action.

    After performing each troubleshooting method, you need to re-initiate the Hexnode Agent app installation from the portal to check whether it is getting installed successfully. Hope this answers your query.

    Cheers!
    Chris Coleman
    Hexnode UEM

  • niklaus

    niklaus

    Participant

    niklaus

    Participant

    The agent got installed after restarting the device. Thanks chris!