IOS device not responding

Avatar
expand collapsive

Hey all!

I have around 200 iOS devices enrolled in Hexnode and they were working fine till a few days back when a few of my devices (around 20) stopped responding. All of them are switched on and also has an active internet connection. But some of them are shown as inactive as well. Here are some of the things that I tried out to fix the issue:

Restart the device

Connect the device to another network

Check the validity of the APNs certificate [still valid – around 125 days left]

There devices are still unresponsive even after performing the above troubleshooting methods. Does someone have any idea on how to fix the issue?

All Replies

  • Rhys

    Rhys

    Participant

    Rhys

    Participant

    Hey, check out this link https://developer.apple.com/forums/thread/28918. It looks like sometimes iPhones/macs can stop responding to APNs and this can make the device unresponsive.

  • Willow

    Willow

    Participant

    Willow

    Participant

    If the devices do stop responding to the APNs randomly and if the APNs certificates are still valid, I think the only option for you is to disenroll your device and enroll them again.

  • Avatar

    Tracy

    Participant

    Tracy

    Participant

    But isnt there any other way that we can fix the issue without enrolling the devices again? Can I not fix this issue from the Hexnode portal?

  • Willow

    Willow

    Participant

    Willow

    Participant

    I’m afraid if there’s something that can be done from the Hexnode end. This is an issue with the Apple server and we cannot do something to fix the issue other than to try to enroll the device again. When the devices get enrolled, the issue with the APNs usually gets solved. I had a read through some forums, and it seems like this is the only way to fix the issue when the device stop responding to the APNs.

  • Rhys

    Rhys

    Participant

    Rhys

    Participant

    The devices that stopped working would have updated its push token. If the device is not able to communicate with the MDM server when the push token is being updated, there will be a token mismatch as the token will not get updated in the MDM server. The device will stop responding to the MDM server once the push tokens do not match. Hence, the only option would be re-enrolling the devices in such a case.

  • Avatar

    Tracy

    Participant

    Tracy

    Participant

    Oh. Thanks a lot man! I guess I’ll have to re-enroll the devices again.. I’m planning to raise a ticket with Apple as well regarding this issue. They should provide a way to troubleshoot this issue without making us re-enroll our devices again. Anyways, thanks again. Bye!