Facing password issue with remote connection after Windows10 device enrollment

expand collapsive

Hello Hexnode Support Team,

I am facing a password related issue, while trying to remote connect to my Windows10 EC2 instance after enrolling with the UEM portal.

Steps followed:

  1. Create a Windows10 EC2 instance, Connect to it using RDP from my laptop, and enroll the device with the UEM – This is successfully completed. I am able to see the enrollment details in the UEM portal.
  2. Close the remote desktop connection session.
  3. After sometime, again initiate a remote desktop connection to the Windows 10 instance. – When I enter the credentials to connect, it fails to connect with the following error:


Unable to connect

We couldn’t connect to the remote PC because you must change your password before signing in. Change your password, or contact your network administrator for assistance.

Error code: 0x1207


I noticed there is a sample password policy assigned to the device in the Hexnode UEM portal during the enrollment. I removed the device from that policy, and also restarted the Windows10 instance. Still I get the above mentioned error.

In effect, I am getting locked out from my Windows10 EC2 instance after enrollment.

Could it be related to some access settings of the device getting changed during the enrolment?

Could you please help to resolve this?



All Replies

  • Hexnode



    Hi Rajesh,

    Welcome to the Hexnode Community,

    Happy to be of help,

    It is not due to any access settings enforced during enrollment but because of the password policy previously applied that caused the local and administrator account to be marked to change the password on the next login. Once you set the password, you’re good to go.

    To set the new password, please try logging in to the EC2 instance using the EC2 serial console. The device automatically prompts you to set a new one. Once set, you will be able to access the device via RDP.

    Feel free to reach out to us if you face any difficulties.


    Catherine George