Developer options not accessible in Android 11 devices

expand collapsive

G’day folks! 
I am rolling with Hexnode for over a year and I got stuck into this problem. So I was trying the Advanced restrictions policy for my Android devices enrolled as Device Owner. I had enabled the option ‘Developer mode’, in Android 10 phones the developer options are accessible but for Android 11 it shows the error saying the action is not allowed. 
Can anybody help me solve this issue?

All Replies

  • Hi Ah lam, thanks for reaching out!
    This might be the issue if the ‘Mock location’ option in your Basic restrictions policy is disabled. This option completely disables the Developer option in your Android device. To enable this option in your portal:

    1. Head on to the Policies tab.
    2. Navigate to Android > Restrictions > Basic.
    3. Enable Mock locations.

    Hope this solution works for you. Please come back if you have any further queries.

    Kenny Markovic
    Hexnode UEM