HexCon is coming to NYC. Catch the early-bird price before the time's up! Book me a spot

App config not sent to deviceSolved

Participant
Discussion
3 years ago

I added an application as a mandatory app and added an app configuration of the same application in the same policy. After associating the policy, only the install application action was present in the action history. When I associated the app configuration in a separate policy, it was listed in the action history. Should app configurations be added separately always?

Replies (3)

Marked SolutionPending Review
Participant
3 years ago
Marked SolutionPending Review

Thanks Chris!

Marked SolutionPending Review
Hexnode Expert
3 years ago
Marked SolutionPending Review

Hey Aitana,

Thank you for reaching out to us!

When you add an application as a Mandatory App and configure the App configuration of the application in the same policy, the app configuration will be sent along with the Install Application command. Hence, a separate app configuration action will not be present inside the Action History. If the app configuration is added in a different policy, you will see the app configuration action inside the Action History tab.

Hope this answers your query.

Cheers!
Chris Coleman
Hexnode UEM

Marked SolutionPending Review
Participant
3 years ago
Marked SolutionPending Review

I really don’t think it is necessary if the app configuration should be added as a separate policy. Did you check the application in the device, whether the configurations were applied on the application in the device end?