Unable to auto-join WiFi on Android

Roxanne
expand collapsive

Recently pushed a Wifi configuration to our Pixel 4a devices running Android 11. In the policy, I have selected the ‘Auto-join’ option but the devices are not connecting to the network automatically even though there was no network in the vicinity the device earlier connected to.

Also, when I go to Wi-Fi settings, I do not see the network saved there but the configuration is visible in the Hexnode MDM app under Policies and when you select the network it gets connected automatically. Is this happening with you too?

Tags:

All Replies

  • Riker Mccarthy

    Riker Mccarthy

    Participant

    Riker Mccarthy

    Participant

    When you configure Wi-Fi for Android, you are shown the following notes –

    • Wi-Fi profiles with WEP security will not get saved on the device.
    • Unlike other devices, the Wi-Fi configurations pushed to the device will not be shown under “Saved Networks” in Settings.
    • In devices where Hexnode MDM app has no notification access privileges, when the device enters the range of a configured Wi-Fi network, users will be asked whether to connect to the Hexnode suggested Wi-Fi network (even if the device is in kiosk mode), manually grant the permission to connect to the network. If declined, any subsequent Wi-Fi configurations pushed will not be saved on the device.


    @roxanne
    if you’re enrolled as Device Admin, take this into consideration.

  • Zach Goodman

    Zach Goodman

    Hexnode

    Zach Goodman

    Moderator

    Hi @roxanne, it is the expected behavior on Android 9. The user will need to manually connect to the network to auto-connect to the network in the future. They may do that by going to Settings > Network & Internet > Wi-Fi and tapping the network. The user will not be asked for the Password.

    If you have allowed Notification access permission to the Hexnode MDM/Hexnode for Work app, the request to auto-join this network should show up in the system notification tray once there is no other connectible network found in range. If not already done, you may manually enable this permission for the Hexnode app from Settings > Apps & notifications > Advanced > Special app access > Notification access. Find the Hexnode app and enable ‘Allow notification access’.

    Regards,
    Zach Goodman
    Hexnode UEM

  • Avatar

    Steeve

    Participant

    Steeve

    Participant

    The Wi-Fi network is shown as disabled. But I am able to click on it to get connected.( sometimes) Wonder why it is shown as disabled…

  • Deborah Timothy

    Deborah Timothy

    Hexnode

    Deborah Timothy

    Moderator

    Hello Steeve,

    Thank you for reaching out to us. This doesn’t seem to be an issue of Hexnode. Please check if it is a network-specific issue. If the issue is with a particular network, it might be due to poor network range. If all the networks are shown to be disabled, make sure to enable the setting Keep Wi-Fi on during sleep. Turn off your Wi-Fi connection and turn it on after some time.

    Hope that fixes it. Do reach out if you continue to face any issues.

    Cheers!!
    Deborah Timothy
    Hexnode UEM