Samsung Smart Switch app not working in AE-DO

expand collapsive

Hi guys, I’m facing trouble in using the Samsung Smart Switch app on the device enrolled in Android Enterprise as Device Owner, it was giving the error stating that “Security policy prevents the use of Smart Switch”. Do you guys know why this error is shown or is there any solution for the same?

All Replies

  • Hexnode

    Darvin

    Moderator

    Hi, @Timothy. Thanks for reaching out on Hexnode Connect!

    Samsung Smart Switch app is blocked on devices enrolled under Android Enterprise Device Owner by default. But you can enable it by setting up managed App Configurations for the app and associating it with the devices.

    1. Navigate to the Policies tab > New policy > New Blank Policy and click on Select.
    2. Select Android and under App Management, choose App Configurations.
    3. Click on Configure, then select Add a new configuration and search for Samsung Smart Switch from the list of available apps. Once you find the application, click on Select.
    4. Please note that the Samsung Smart Switch app will appear in the list of applications available for App Configurations only if you have added the app to the app repository.
    5. After clicking on Select, a dialog box will appear for configuring the Samsung Smart Switch Mobile application. Toggle on the “Allow Smart Switch to Run” button to enable Samsung Smart Switch on the device.
    6. Enable Smart Switch via App Configurations

    7. Now, go to Policy Targets and add the devices to which you want to associate the App Configuration. Then, click on Save.

    Once the policy is associated with the device, you will be able to access the application without any prompts or warnings. We hope this resolves your issue. Please feel free to reach out to us if you have any further queries.

    With regards,
    Darvin Hudson
    Hexnode UEM

     

  • Hexnode

    Darvin

    Moderator

    Hi @timothy, the solution mentioned earlier in the discussion generally resolves the issue. However, it appears that the Samsung Smart Switch app might cause this issue randomly. Please try uninstalling and then reinstalling the app. Additionally, there is another fix you can consider: configuring and deploying the Knox Service Plugin app under the Android Restrictions policy to enable the Samsung Smart Switch application.

    1. Navigate to the Policies tab > New policy > New Blank Policy and click on Select.
    2. Select Android. Under Restrictions, choose Knox Service Plugin.
    3. Once you’ve added and approved the KSP app, you can proceed to configure it.
    4. In Knox Service Plugin, click on Configure.
    5. A list of configurable options will appear. First, provide a profile name. For example, use “Allow Smart Switch.”
    6. Naming the Knox Service Plugin profile

    7. Next, under Device Wide policies, toggle on “Enable device policy controls.”
    8. Enable device policy controls in KSP

    9. Moving on to Device restrictions in the list, enable both “Enable device restriction controls” and “Allow Smart Switch” toggle buttons.
    10. Enable device restriction controls in KSP

      Toggle on Allow Smart Switch in KSP

    11. After enabling these options, scroll to the end of the list of available configurations and click on Done.
    12. Now, go to Policy Targets and add the devices to which you want to associate the KSP configuration. Then, click on Save.
    13. Please note that once the policy is associated, you should install the Knox Service Plugin app on the device for the configured settings to take effect.

    Once the policy is connected to the device and the Knox Service Plugin app is installed, you’ll be able to access the Samsung Smart Switch application without any restrictions. We hope this solves your issue. Feel free to reach out to us if you have any further questions.

    With regards,
    Darvin Hudson
    Hexnode UEM