Prevent “Hexnode Remote View permission request” on device

Avatar
expand collapsive

When the Remote View Start Session is invoked from Hexnode, the device displays a permission request dialog box to the device’s user with the options ‘Cancel’ and ‘Start Now’.

Issues:
1) can this be set remotely (via Policy) so that the Remote View will always start and does not require the device’s user to press ‘Start Now’?

2) if the permission request dialog box on the device is not acknowledged (either ‘Cancel’ or ‘Start Now’) and the Hexnode controller ends their attempt at remote view, the permission request dialog box remains permanently on the device. How to clear it?

Context: we are using Android 9 tablets as anonymous, locked down kiosks displaying a single app in public spaces.

All Replies

  • Avatar

    Eva Tyler

    Moderator

    Eva Tyler

    Moderator

    Hi Matt,

    Thanks for reaching out to us!

    Unattended access for Remote View is possible for Android devices version 9.0 and below.
    When the Remote View app is set up for the first time, a device prompt appears that shows the checkbox ‘Do not show again’. Enabling this option grants unattended access for remotely viewing the device.

    With Android 10 devices, Google strengthened its security mechanism, so the ‘Do not show again’ prompt does not appear anymore. This would mean that access needs to be granted each time to remotely view the device screen.

    However, in order to cope up with this situation, Hexnode has introduced the Remote view app version 4.5 and above in such a way that, it gets unattended access once the permission is granted until the app instance is killed in the device. Rebooting a device can kill the app instance, so you need to grant the permission again.

    The permission request needs to be cleared manually from the device, however, please do try the above and in case of any issues, feel free to comment.

    Cheers!
    Eva Tyler
    Hexnode MDM