Opening a web app shows an error

Avatar
expand collapsive

Hey guys,

I’ve added some of the web apps in the kiosk mode. Most of them function smoothly but one of them is driving me off my head. Every time I open it something like “You don’t have the privilege to access it” shows up. I only created the web app kiosk policy for the devices and still it saying I’m underprivileged😉 Jokes apart, I’m not aware what makes this particular url inaccessible. Is this because of some error in the policy or due to issues with the site?

Tags:

All Replies

  • Avatar

    Noah Ruther

    Participant

    Noah Ruther

    Participant

    recheck the web app URL. Make sure it is accessible on some other device.

  • Avatar

    Maitha

    Participant

    Maitha

    Participant

    @Noah Thanks. I cross-checked it with the web app added to the inventory also. But the same URL opens in another macOS device of mine. The issue is with the device in kiosk.

  • Avatar

    Catherine George

    Hexnode

    Catherine George

    Moderator

    Hi Maitha,

    Happy to help!

    I’m unclear about the OS platform of the kiosk-enabled device. Sorry about that! Still, this issue often occurs on iOS and Android devices running the web app kiosk mode. For example, when you fail to include the sub-domains that the user is supposed to access via the web app in the kiosk policy, the device might prompt that the URL is inaccessible. Also, since a website URL may differ for mobile and desktop, only the URL added as the web app gets whitelisted. Thus, if any mobile-specific subdomain exists for the web app, it will be restricted on the device. When the user tries to access it, it will be inaccessible.

    You can resolve this issue by explicitly whitelisting all the necessary website URLs as they appear on the device when you access them before enabling the kiosk. Either you can add all the required URLs (including the mobile-specific sub-domains) as web apps and add each of them to the web app kiosk policy. Or you may whitelist all the necessary URLs in the kiosk policy.

    In case of an Android device, if you want to whitelist any specific websites that the user should access, you may specify them by navigating to Policy > Kiosk Lockdown > Android Kiosk Lockdown > Website Kiosk Settings > Whitelist websites.

    Android web apps kiosk policy – whitelist URLs

    For iOS devices, you can specify the external links to be accessed within the web app in the kiosk lockdown policy by navigating to Policies > Kiosk Lockdown > iOS Kiosk Lockdown > Web App > Whitelist websites.

    iOS web app kiosk policy - whitelist URLs

    I hope this helps!

    Catherine George
    Hexnode UEM

  • Avatar

    Noah Ruther

    Participant

    Noah Ruther

    Participant

    Oh! I wasn’t aware that we can also whitelist URLs explicitly. I went for background apps whenever I need to make specific websites accessible for the user on a web app kiosk. Shud try this too.

  • Avatar

    Maitha

    Participant

    Maitha

    Participant

    It was the incorrect URL that prompted the message. When I added the mobile URL for the given website as the web app, I was able to access it. Thanks @catherine-george.

  • Avatar

    Catherine George

    Hexnode

    Catherine George

    Moderator

    Always here to help you!

    @Maitha
    @Noah Reach out to us for more queries.