Non store apps not getting installed in Windows

Avatar
expand collapsive

I was trying to deploy some apps to my Windows device. But only the store apps got installed and the enterprise app installation failed. I tried pushing the enterprise apps individually using the Install Application action but the app still didn’t get installed. Is this an issue on the Hexnode end? Please check.

All Replies

  • Avatar

    Pepijn

    Participant

    Pepijn

    Participant

    I did try around 7-10 different applications and none of them seems to get installed. Only store apps are getting installed in the device. But those applications got installed in my other devices when I checked now.

  • Avatar

    Jimena

    Participant

    Jimena

    Participant

    Maybe your device is not compatible with those versions of the enterprise apps. Did you try installing a different set of applications? Maybe they might get installed.

  • Avatar

    Remy Parker

    Participant

    Remy Parker

    Participant

    Can you try installing the same enterprise apps manually in your device. If they are still not getting installed, we can eliminate the possibility of an error occurring from the Hexnode’s side.

  • Avatar

    Pepijn

    Participant

    Pepijn

    Participant

    The apps are not getting installed when I tried installing them manually as well

  • Avatar

    Remy Parker

    Participant

    Remy Parker

    Participant

    I think this is an OS related issue. Can you check the OS version of your lap. Is it running on Windows 10 S version?

  • Avatar

    Pepijn

    Participant

    Pepijn

    Participant

    Yes, it is running on Windows 10 S version. Will the enterprise apps not get installed in this version at all? Is there some setting that I can change to install them in this device?

  • Chris Coleman

    Chris Coleman

    Hexnode

    Chris Coleman

    Moderator

    Hey Pepijn,

    Thank you for reaching out to us!

    If your device is running on Windows 10 in S mode, you will only be able to install applications that are available in the Microsoft Store. Windows 10 in S mode is developed by Microsoft to focus mainly on performance and security. To increase security, you will only be able to install Microsoft Store apps in those devices. You will not be able to install any non-store applications downloaded from the internet.

    You need to switch to Windows 10 Home or Windows 10 Pro edition to install applications that are not from the Microsoft Store. To switch from S mode,

    1. Navigate to Settings > Update and Security > Activation. In the Switch to Windows 10 Home or Switch to Windows 10 Pro, select Go to the Store.
    2. You will get navigated to the Switch out of S mode page in the Microsoft Store. Click on the Get button. Once the confirmation message appears on your screen, you will be able to install any non-store applications downloaded from the internet on your device.

    Hope this answers your query.

    Cheers!
    Chris Coleman
    Hexnode UEM

  • Avatar

    Pepijn

    Participant

    Pepijn

    Participant

    Thanks Chris for the update.