Exiting kiosk mode in a device that is not connected to a network

Avatar
expand collapsive

can you explain me how can I disable kiosk mode directly on an android device without internet connection?

All Replies

  • Avatar

    Grace Baker

    Hexnode

    Grace Baker

    Moderator

    Hey, Thanks for reaching out to us.

    • You can tap on the Kiosk home screen 10 times fast and enter the kiosk exit password to exit the kiosk mode on an Android device.
    • This password can be configured through a policy or you can use the global passcode. If the password is configured through policy, please navigate to Kiosk Lockdown-> Android Kiosk Lockdown-> Kiosk Exit Settings in the kiosk policy to find the password.
    • If the password is not configured through the policy, navigate to Admin-> General Settings-> Global Exit Settings (Android) to find the global passcode that can be used to exit the kiosk mode.

    To disable kiosk mode, while the device got stuck with an open app, follow the below steps;

    • For Android devices with OS version 8 and below, enable the option ‘Exit manually from kiosk mode while an app is open’ under Kiosk Lockdown -> Android Kiosk Lockdown -> Kiosk Exit Settings (Works only if the Enable status bar under Peripheral settings has been disabled). You can then tap on the top left of the screen and provide the kiosk exit password.
    • For Android devices with OS version 8 and above, navigate to Kiosk Lockdown -> Android Kiosk Lockdown-> Kiosk Exit Settings and enable the option ‘Reboot to exit from kiosk mode’ and provide the time delay for the app to relaunch. After rebooting, tap on the vacant part of the screen 10 times and provide the kiosk exit password to exit from the kiosk mode.

    Kindly use the help link to know more about the kiosk exit of Android devices.

    Cheers!
    Grace Baker
    Hexnode MDM

  • Sterling

    Sterling

    Participant

    Sterling

    Participant

    A few of my android device enrolled in hexnode wasn’t connected to the internet for 6 months. When I got it connected to the internet, the device was in kiosk (guess the device was put in kiosk before so no surprises there) but I couldn’t exit from the hexnode portal. I realized that the device is not communicating with Hexnode. Luckily, these devices were with me so I used the tapping method mentioned above and it worked. But I was just wondering what could I have done if the devices were not with me.

  • Deborah Timothy

    Deborah Timothy

    Hexnode

    Deborah Timothy

    Moderator

    Hello Sterling,

    Thank you for reaching out to us. Looks like you have an older version of the Hexnode app. In the future, make sure that all your devices have the updated version of the Hexnode app. Also enable foreground sync on your devices. To use foreground sync, apply a policy that has set the Periodic Sync to Foreground Service or change the Periodic Sync settings in Admin > General Settings > Periodic sync behavior to Foreground service.

    Once the devices with the latest Hexnode app connect to a network, it will communicate with the Hexnode portal even if it has been offline for a long time. If these devices are in kiosk, you can easily exit from the kiosk via the portal.

    Cheers!!
    Deborah Timothy
    Hexnode UEM