Google Play service action required prompt

expand collapsive

Hey!

I’m facing some unfamiliar issues with Google services on my Android device after enrolling it using G-Suite admin credentials via Hexnode UEM. Here is a breakdown of the situation:

  1. Enrolled the device with G-Suite admin credentials via the Android Enterprise Device Owner method.
  2. Added G-Suite user account after setting up the device.
  3. Deleted the G-Suite admin account.
  4. Attempted to access the Google services like Gmail and Play Store but got redirected to the Hexnode UEM homepage after showing up the “Checking info” prompt.
  5. Also, a warning message “Account action required” from Google Play services appeared.

Has anyone else encountered this problem? Any suggestions or thoughts on why this is happening and how can I fix this?

All Replies

  • Participant

    Frida

    Participant

    Yeah! I kept both G-Suite admin and user accounts at the same time and tried switching from admin to user account, but the result was the same.

    Also, I tried adding a Gmail account instead of the G-Suite user account, and checked the following case:

    1. Switched between the G-Suite admin account and the Gmail account.
    2. Deleted the G-suite admin account after adding the Gmail account.

    For both cases, the Google services were completely accessible.

  • Participant

    hazel

    Participant

    Hi @Frida, I’ve had the same experience with G-Suite admin and user accounts. Enrolled my device using G-Suite admin credentials, and then added a G-Suite user account. When I switched to the user account, all Google services were blocked, and every Google app I opened kept redirecting me to the Hexnode UEM app homepage.

    • This reply was modified 3 weeks, 1 day ago by  Ben.
    • This reply was modified 3 weeks, 1 day ago by  Ben.
    • This reply was modified 3 weeks, 1 day ago by  Ben.
  • Hi @Frida,

    Thanks for reaching out to us.

    Upon checking the issues you raised, we have found that the problem occurs when trying to use a Google Workspace user account on a device enrolled through Android Enterprise Device Owner using Google Workspace admin credentials. Please consider the following suggestions to solve this.

    1. If you have enrolled your device as the Android Enterprise Device Owner using Google Workspace admin credentials and you wish to use Google services, it is recommended to continue using the same admin account on the device.
    2. If you prefer using a different user account for Google services, it is recommended to perform a device reset. After the reset, you can proceed to enroll the device with the specific user account you want. If you opt for a Gmail account instead of a Google Workspace admin account after deleting the admin account, the access to Google services on the device remains unchanged. However, the features that can be deployed from Hexnode UEM to the device will become restricted. The issue arises when the account used to enroll the device is no longer available on the device.

    By following the suggested solutions, you should be able to resolve the problem. If you have any further difficulties or questions, feel free to reach out.

    With Regards,

    Ben Clarke

    Hexnode UEM