Enterprise app repeatedly getting rebooted in Single app kiosk mode

Avatar
expand collapsive

I have around 150 devices in my company which are running in single app kiosk mode. Recently when I tried updating my enterprise app which was running in the kiosk mode, the app keeps force rebooting in some devices. Has someone faced a similar issue like this?

All Replies

  • Avatar

    Fitri

    Participant

    Fitri

    Participant

    Hey man, can you check the update file which you have used. It might be an issue with the new update file.

  • Avatar

    Hester

    Participant

    Hester

    Participant

    I don’t think it’s the issue with the update file.. I have installed the same file in my other devices which are not in kiosk mode and it seems to be working fine in those devices.. This issue is coming only on my devices which are in kiosk mode..

  • Avatar

    Reza

    Participant

    Reza

    Participant

    Hey Hester, did you get any blocked package errors when you tried updating the app?

  • Avatar

    Hester

    Participant

    Hester

    Participant

    Yes I did see a few. I tried adding them as background apps and the issue was still present.. Anyone got any idea on this issue..?

  • Avatar

    Fitri

    Participant

    Fitri

    Participant

    hmm looks like a very uncommon issue. Is it happening to any particular device or is it happening to all your devices?

  • Avatar

    Hester

    Participant

    Hester

    Participant

    Yeah actually all the Galaxy Tabs are facing the issue. I havent seen the issue in any of the other devices as of now.

  • Chris Coleman

    Chris Coleman

    Hexnode

    Chris Coleman

    Moderator

    Hey Hester,

    Thank you for reaching out to us!

    The issue that you are facing is a very specific and uncommon issue. Fortunately, we were able to reproduce the issue and also were able to find a suitable solution for it as well. We have formulated a troubleshooting method for it, and the steps that need to be followed are given below:

    1. Navigate to Policies > New Policy > Kiosk Lockdown > Peripheral Settings.
    2. Check the “Enable Recent apps button” option.
    3. Associate the policy to your devices.
    4. If the issue gets resolved after enabling the recent apps button, you can proceed with the remaining steps in order to get a permanent fix for all your devices that faced a similar issue.
    5. Uncheck the “Enable Recent apps button” option.
    6. Navigate to Background Apps and add “com.android.systemui” as a background app.
    7. Associate the policy to your devices and save the policy.

    This should permanently fix the issue that you’re facing with your enterprise application. A possible side effect of adding “com.android.systemui” as a background app is that the Recent Apps button might get automatically enabled in the device even if it is disabled in the policy.

    I really hope this will solve the issue on your devices. If the issue still persists, you can always reach out back to us, and we will be happy to help you out.

    Cheers!
    Chris Coleman
    Hexnode UEM

  • Avatar

    Hester

    Participant

    Hester

    Participant

    Hey Chris! After adding “com.android.systemui” as a background app, the app seems to be working fine in kiosk mode now. Thanks a lot for the help again guys.!