Unsupported Screen Size: The viewport size is too small for the theme to render properly.

Blocked package in Android Kiosk – Adding the app pdf viewer

Mobile Device Management Community Forums Kiosk Management Blocked package in Android Kiosk – Adding the app pdf viewer

This topic contains 1 reply, has 2 voices, and was last updated by  Hexnode Support 1 month, 3 weeks ago.

Viewing 2 posts - 1 through 2 (of 2 total)
  • Author
    Posts
  • #409 Score: 0

    PbK
    Participant

    hello, when I am adding the app pdf viewer and apply it to the policy I’m still getting the following message blocked package: com.google.android.apps.docs how can i resolve this .

    #753 Score: 0

    Hexnode Support
    Keymaster

    Hi,

    Even though you have added your preferred PDF viewer in the Kiosk policy, it has not been set as the default viewer for PDF files. Google Docs/Drive app is your current default viewer. So, whenever you try to open a PDF file, Google Drive/Docs attempts to launch itself and since it has not been added in the Kiosk policy, you get the blocked package error.

    So, here’s what you do. On the device,

    1. Exit Kiosk mode and open Settings > Apps
    2. Scroll down to Drive (Google Drive app) and tap open the app settings
    3. Select Open by default and tap on Clear Defaults

    You can now enable Kiosk mode again. When you open a PDF file again, you will no longer receive the package blocked error, instead, you’ll be asked to select an app to open the file. Choose your preferred PDF viewer and tap the Always use confirmation to set it as the new default viewer. You should now be able to view PDF files while in Kiosk mode.

    Thanks and regards
    Hexnode Support Team
    +1-866-498-9407 (US Toll Free)
    +44-(800)-3689920(UK Toll Free)
    +61-1800165939 (Australia Toll Free)
    +1-510-545-9700 (Intl)
    Hexnode | Mitsogo Inc.

     

Viewing 2 posts - 1 through 2 (of 2 total)

You must be logged in to reply to this topic.