Android Remote View: Partial remote view screen

Roxanne
expand collapsive

There is an odd behavior in remotely view for our Android device. We have deployed some device in kiosk for our shops but when we start remote view session on Hexnode MDM it is taking only half of the screen for displaying. Do tell if I was not clear in explaining the situation, can anyone tell how to fix this?
Also
Rotating the device will also rotate the remote view but still showing only half the screen.

All Replies

  • Zach Goodman

    Zach Goodman

    Hexnode

    Zach Goodman

    Moderator

    Hi @Roxanne, sorry you had to face that.

    Did you mean like only half of your display screen shows up on the remote view window on Hexnode? How does it appear, the display fills the remote view window, or the display makes up for half the area of the remote view window?
    Also, is the problem re-occurring even outside kiosk mode?

    Regards,
    Zach Goodman
    Hexnode UEM

  • Roxanne

    Roxanne

    Participant

    Roxanne

    Participant

    Hi @Zach-goodman, yes. I tried to add a screenshot of the issue here but some error is showing up while adding image.
    I’ll will just try to explain it as best as I can, the remote view screen shows half of the display and the rest half is black. The orientation is also wrong. It seems like when Im viewing in landscaping mode, the device is rotated in portrait mode and vice versa. Even rotating the remote view screen is not solving this issue.

  • Zach Goodman

    Zach Goodman

    Hexnode

    Zach Goodman

    Moderator

    @Roxanne, not sure what might be causing this for you. But it seems like something to do with the display properties returned for the remote view. This could be fixed by setting up a screen orientation property for your device from Policies > New Policy (you could also add these settings on your kiosk policy itself) > Android > Restrictions > Allow Device Functionality > Screen Orientation and setting the option to a view you would like.

    Regarding rotating the remote view window not having an effect on the view; consider the remote view window as a virtual device holder, rotating this holder will rotate only the container and not the device display inside. Only when the device display is rotated for the physical device, the remote view display (not the container) will rotate accordingly into the portrait or landscape mode. This is very similar to having a phone holder on a bike. If the display is rotated to landscape mode (say while displaying the map) but you have the holder on upright position, you might want to adjust the phone holder accordingly.

    Cheers!
    Zach Goodman
    Hexnode MDM

  • Roxanne

    Roxanne

    Participant

    Roxanne

    Participant

    @Zach we tried your suggestion on one device and the issue is resolved on that device. I’ll soon try this out on the other devices.

  • Zach Goodman

    Zach Goodman

    Hexnode

    Zach Goodman

    Moderator

    @Roxanne, glad it worked for you!

  • Birdie

    Birdie

    Participant

    Birdie

    Participant

    @roxanne I think there may be some discrepancies in the display rotation property returned for your device. Like its confusing between the default display mode.
    Or maybe some problem with the accelerator calibration on your devices or a third-party app messing up with your display properties.
    My take is –
    1. Try out safe mode to check if a third-party app is causing this.
    2. Try enabling Developers Mode and disabling HW overlay. This fixes a lot of display issues but your device may become slower.