Reply To: Enterprise app repeatedly getting rebooted in Single app kiosk mode

Chris ColemanChris Coleman
-1 pt

Hey Hester,

Thank you for reaching out to us!

The issue that you are facing is a very specific and uncommon issue. Fortunately, we were able to reproduce the issue and also were able to find a suitable solution for it as well. We have formulated a troubleshooting method for it, and the steps that need to be followed are given below:

  1. Navigate to Policies > New Policy > Kiosk Lockdown > Peripheral Settings.
  2. Check the “Enable Recent apps button” option.
  3. Associate the policy to your devices.
  4. If the issue gets resolved after enabling the recent apps button, you can proceed with the remaining steps in order to get a permanent fix for all your devices that faced a similar issue.
  5. Uncheck the “Enable Recent apps button” option.
  6. Navigate to Background Apps and add “” as a background app.
  7. Associate the policy to your devices and save the policy.

This should permanently fix the issue that you’re facing with your enterprise application. A possible side effect of adding “” as a background app is that the Recent Apps button might get automatically enabled in the device even if it is disabled in the policy.

I really hope this will solve the issue on your devices. If the issue still persists, you can always reach out back to us, and we will be happy to help you out.

Chris Coleman
Hexnode UEM