App permissions in kiosk mode 

expand collapsive

Last day we were testing the kiosk mode in our oneplus nord. We pushed some apps to the device and then put the device in the kiosk mode. And after the device entered the kiosk mode, we launched the device. The app needed some permissions to work but when we tried to grant these, it just closes the app and redirects to the home screen. Tried launching the app again, same result. Now we cant use the app in the kiosk mode. Does anyone have info about this. If yes, please fill me in coz it would be helpful.

All Replies

  • Participant

    Chizu

    Participant

    I got another experience while testing the same scenario. I tried the kiosk with Truecaller and I can grant the permissions through app while I am in the kiosk state. Maybe the fault of the app you used?

  • Hexnode

    Johan Blake

    Moderator

    Hey @aimi and @chizu,
    Welcome to the Hexnode community.

    Applications may redirect to the Settings app on initial launch to grant the required permissions. If an app tries to redirect to another app that is not present in the kiosk app list during kiosk mode, the app may close abruptly. Add the Settings app in the kiosk mode to avoid the issue.
    Another alternative is to provide the required permissions for the app before locking the device in kiosk mode. This will not require the Settings app to be included as a kiosk app.

    Hey @chizu, some apps allow in-app permissions, eliminating the need to switch to the Settings app to grant the necessary permissions. As a result, when the app prompts for permissions, the user can grant them directly, without the Settings app added to the kiosk. The process for granting the required permissions relies entirely on the app in use.

    Hope it serves your needs.
    Reach out to us if you have more queries.
    Johan Blake
    Hexnode UEM