Reply To: pair with the device window gets blocked

#755 Score: 0
AvatarHexnode Support
Keymaster
6 pts

Hi, Kyden,

We already whitelist almost all of the Bluetooth services by default. Now that Bluetooth pairing is blocked on your device, it means the Package name of one or more of your Bluetooth services is not included in our whitelist. If you could check your device’s Bluetooth services apps and add them in the Kiosk policy, pairing should work just fine.

Here’s a handy app that lets you view the Package names

Install the app and note down the Package Names of the apps that seem like Bluetooth services. Now,

  1. Add those apps to your App inventory
    1. Go to Admin > App settings > Apps
    2. Click on the Add Apps button and select With Bundle ID
    3. Type in the Bundle ID you have identified for your Bluetooth service
    4. Click Add. It will now be available in your App inventory. Repeat if you have other apps.
    5. Here’s a screencast on adding apps by their Bundle IDsAdd-Custom-App-With-Package-Name
  2. Whitelist it in Kiosk
    1. Go to your Kiosk policy and whitelist the app.
      Here’s the complete Kiosk guide
  3. Hide the app icon
    There is no reason to keep the Bluetooth services app within the Kiosk. You should consider hiding the app icon.

    1. Here’s a help article on hiding the apps from the Kiosk screen
      Once you’re done, Save the Kiosk policy.

The updated policy will be pushed to the device and you should have no trouble pairing with other Bluetooth devices.

Thanks and regards
Hexnode Support Team
+1-866-498-9407 (US Toll Free)
+44-(800)-3689920(UK Toll Free)
+61-1800165939 (Australia Toll Free)
+1-510-545-9700 (Intl)
Hexnode | Mitsogo Inc