# How to retrieve Mac device logs

Retrieving Mac device logs are vital in troubleshooting Mac devices. macOS uses the application **Console** to collect logs generated by your Mac device. Error logs collected in **Console** application can prove to be very crucial in diagnosing issues faced by the device.

Retrieving Mac Device logs using Console on macOS Sierra (10.12) and later versions
-----------------------------------------------------------------------------------

To retrieve logs from **Console**.

1. Launch **Console** application from **Utilities** folder in **Applications**. **Console** is also available on running a quick search on **Launchpad** or **Spotlight Search**.
2. Clicking the sidebar toggle button retrieves the side bar if previously hidden.
3. Click on **All Messages** in the toolbar.
4. The **Activities** button if ON (indicated by its blue color) needs to be turned OFF with a click.
5. Try to bring about the issue that required troubleshooting. This ensures that the issue is logged in by **Console**.
6. Switch back to **Console** and select the recent message. From the **Menu Bar** go to **Edit > Select All**, followed by **Edit > Copy**.
7. Launch **TextEdit** application from **Launchpad** and select **New Document**.
8. From the menu bar click on **Edit > Paste** to paste the logs in the new document.
9. From the menu bar click on **File > Save** to save the document. Save the file in **Rich Text Document** format to a suitable location in **Finder**. Attach the above file while troubleshooting the issue.

![When the Activities button is ON, mac device logs are grouped by the activities they are associated with in Console app.](https://cdn.hexnode.com/mobile-device-management/help/wp-content/uploads/2019/09/Mac-device-logs-collected-in-Console-app.png)The **Console** application shown above has **Activities** button as ON.Retrieving Mac Device logs using Console on macOS Capitan (10.11) and earlier versions
--------------------------------------------------------------------------------------

1. Launch **Console** application from **Utilities** folder in **Applications**.
2. If on the extreme left of the toolbar it shows **Show Log List**, click on it. This opens a sidebar with **System Log Queries** and **Files**. You can skip this step if it shows **Hide Log List**.
3. Click on **All Messages** under **System Log Queries**.
4. Try to bring about the issue that required troubleshooting. This ensures that the issue is logged in by **Console**.
5. Switch back to **Console** and from the **Menu Bar** choose **File > Save a Copy As** and save the file to a suitable location in **Finder**. Attach the above file while troubleshooting the issue.