Reply To: Would like to enable Pop-ups in safari on ipads

#627 Score: 0
AvatarHexnode Support
Keymaster
6 pts

Hi Mohd,

It could be that you have chosen to disable it with an iOS restrictions policy via Hexnode MDM. Here’s how you can re-enable them.

On your Hexnode MDM portal,

  1. Head over to Management > Devices
  2. Click open the iPad to view the device details
  3. Now, go to Policies section
    You can see the list of policies assigned to the device. If you see more than one, and can’t identify the policy in which you have configured the iOS restrictions, you might have to open up each policy.
  4. Now, click open a policy
  5. Click the Manage button up top and select Modify
  6. Under iOS settings, choose Restrictions
  7. Click Configure and scroll down to Allow Safari
  8. Under Allow Safari, you’ll see that Block pop-ups is checked.
  9. Un-check it and Save the policy (Save button is down below).
  10. If it has already been unchecked, then we have the wrong policy.
    Just go back to the device details page and try this with another policy.

Even if you have found the correct policy and re-enabled pop-ups, it might be a good idea to check other policies and make sure you have not blocked them in any.

When you configure multiple policies, the most restrictive setting is applied. It doesn’t matter if you have allowed pop-ups in one or more policies, they will remain disabled on the device as long as you have at least one policy configured to have it blocked on the device!