Reply To: Unable to auto-join WiFi on Android

#12948
Zach GoodmanZach Goodman
Moderator
5 pts

Hi @roxanne, it is the expected behavior on Android 9. The user will need to manually connect to the network to auto-connect to the network in the future. They may do that by going to Settings > Network & Internet > Wi-Fi and tapping the network. The user will not be asked for the Password.

If you have allowed Notification access permission to the Hexnode MDM/Hexnode for Work app, the request to auto-join this network should show up in the system notification tray once there is no other connectible network found in range. If not already done, you may manually enable this permission for the Hexnode app from Settings > Apps & notifications > Advanced > Special app access > Notification access. Find the Hexnode app and enable ‘Allow notification access’.

Regards,
Zach Goodman
Hexnode UEM